<!doctype html >
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="no-js ie9 oldie" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
    <title>Editorial: The mask returns | TBR News Media</title>
    <meta charset="UTF-8" />
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <meta name="author" content="TBR Staff">
    <link rel="pingback" href="https://tbrnewsmedia.com/xmlrpc.php" />

    <meta property="og:image" content="https://tbrnewsmedia.com/wp-content/uploads/2021/12/editorial-masks_stock-photo-e1639685355303.jpg" /><meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="TBR News Media &raquo; Feed" href="https://tbrnewsmedia.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="TBR News Media &raquo; Comments Feed" href="https://tbrnewsmedia.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="TBR News Media &raquo; Editorial: The mask returns Comments Feed" href="https://tbrnewsmedia.com/editorial-the-mask-returns/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/tbrnewsmedia.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://tbrnewsmedia.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://tbrnewsmedia.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='swpm.common-css'  href='https://tbrnewsmedia.com/wp-content/plugins/simple-membership/css/swpm.common.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-opensans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700&#038;subset=latin%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%2Clatin-ext%2Ccyrillic&#038;ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-ubuntu-css'  href='https://fonts.googleapis.com/css?family=Ubuntu%3A300%2C400%2C500%2C700%2C300italic%2C400italic%2C500italic%2C700italic&#038;subset=latin%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Clatin-ext%2Ccyrillic&#038;ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-pt-sans-css'  href='https://fonts.googleapis.com/css?family=PT+Sans%3A400%2C700%2C400italic&#038;subset=latin%2Ccyrillic-ext%2Clatin-ext%2Ccyrillic&#038;ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-oswald-css'  href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C300%2C700&#038;subset=latin%2Clatin-ext&#038;ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='google-roboto-cond-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A300italic%2C400italic%2C700italic%2C400%2C300%2C700&#038;subset=latin%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%2Clatin-ext%2Ccyrillic&#038;ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='google-vollkorn-css'  href='https://fonts.googleapis.com/css?family=Vollkorn%3A400italic%2C700italic%2C400%2C700&#038;ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-bootstrap-css'  href='https://tbrnewsmedia.com/wp-content/themes/Newspaper/includes/wp_booster/external/bootstrap/td-bootstrap.css?ver=4.5d' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://tbrnewsmedia.com/wp-content/themes/Newspaper-child/style.css?ver=4.5d' type='text/css' media='all' />
<script type='text/javascript' src='https://tbrnewsmedia.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://tbrnewsmedia.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://tbrnewsmedia.com/wp-json/" /><link rel="alternate" type="application/json" href="https://tbrnewsmedia.com/wp-json/wp/v2/posts/136336" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tbrnewsmedia.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://tbrnewsmedia.com/wp-includes/wlwmanifest.xml" /> 
<link rel="canonical" href="https://tbrnewsmedia.com/editorial-the-mask-returns/" />
<link rel='shortlink' href='https://tbrnewsmedia.com/?p=136336' />
<link rel="alternate" type="application/json+oembed" href="https://tbrnewsmedia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftbrnewsmedia.com%2Feditorial-the-mask-returns%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://tbrnewsmedia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftbrnewsmedia.com%2Feditorial-the-mask-returns%2F&#038;format=xml" />
<script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":136336,"post_name":"editorial-the-mask-returns","post_title":"Editorial: The mask returns","post_type":"post","post_author":"4","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":255,"name":"Columns","slug":"columns","term_group":0,"term_taxonomy_id":255,"taxonomy":"category","description":"","parent":0,"count":2484,"filter":"raw","cat_ID":255,"category_count":2484,"category_description":"","cat_name":"Columns","category_nicename":"columns","category_parent":0},{"term_id":257,"name":"Editorials","slug":"editorials","term_group":0,"term_taxonomy_id":257,"taxonomy":"category","description":"","parent":256,"count":272,"filter":"raw","cat_ID":257,"category_count":272,"category_description":"","cat_name":"Editorials","category_nicename":"editorials","category_parent":256},{"term_id":29,"name":"Health","slug":"health","term_group":0,"term_taxonomy_id":29,"taxonomy":"category","description":"","parent":0,"count":1049,"filter":"raw","cat_ID":29,"category_count":1049,"category_description":"","cat_name":"Health","category_nicename":"health","category_parent":0},{"term_id":256,"name":"Opinion","slug":"opinion","term_group":0,"term_taxonomy_id":256,"taxonomy":"category","description":"","parent":0,"count":857,"filter":"raw","cat_ID":256,"category_count":857,"category_description":"","cat_name":"Opinion","category_nicename":"opinion","category_parent":0},{"term_id":168,"name":"Port Times Record","slug":"port-times-record","term_group":0,"term_taxonomy_id":168,"taxonomy":"category","description":"","parent":0,"count":3609,"filter":"raw","cat_ID":168,"category_count":3609,"category_description":"","cat_name":"Port Times Record","category_nicename":"port-times-record","category_parent":0},{"term_id":173,"name":"Times of Huntington-Northport","slug":"times-of-huntington-northport","term_group":0,"term_taxonomy_id":173,"taxonomy":"category","description":"","parent":0,"count":3213,"filter":"raw","cat_ID":173,"category_count":3213,"category_description":"","cat_name":"Times of Huntington-Northport","category_nicename":"times-of-huntington-northport","category_parent":0},{"term_id":171,"name":"Times of Middle Country","slug":"times-of-middle-country","term_group":0,"term_taxonomy_id":171,"taxonomy":"category","description":"","parent":0,"count":2272,"filter":"raw","cat_ID":171,"category_count":2272,"category_description":"","cat_name":"Times of Middle Country","category_nicename":"times-of-middle-country","category_parent":0},{"term_id":172,"name":"Times of Smithtown","slug":"times-of-smithtown","term_group":0,"term_taxonomy_id":172,"taxonomy":"category","description":"","parent":0,"count":2796,"filter":"raw","cat_ID":172,"category_count":2796,"category_description":"","cat_name":"Times of Smithtown","category_nicename":"times-of-smithtown","category_parent":0},{"term_id":170,"name":"Village Beacon Record","slug":"village-beacon-record","term_group":0,"term_taxonomy_id":170,"taxonomy":"category","description":"","parent":0,"count":3165,"filter":"raw","cat_ID":170,"category_count":3165,"category_description":"","cat_name":"Village Beacon Record","category_nicename":"village-beacon-record","category_parent":0},{"term_id":169,"name":"Village Times Herald","slug":"village-times-herald","term_group":0,"term_taxonomy_id":169,"taxonomy":"category","description":"","parent":0,"count":4232,"filter":"raw","cat_ID":169,"category_count":4232,"category_description":"","cat_name":"Village Times Herald","category_nicename":"village-times-herald","category_parent":0}]; _mmunch['postTags'] = [{"term_id":22471,"name":"Covid 19","slug":"covid-19","term_group":0,"term_taxonomy_id":22471,"taxonomy":"post_tag","description":"","parent":0,"count":255,"filter":"raw"},{"term_id":18730,"name":"editorial","slug":"editorial","term_group":0,"term_taxonomy_id":18730,"taxonomy":"post_tag","description":"","parent":0,"count":139,"filter":"raw"},{"term_id":22573,"name":"Masks","slug":"masks","term_group":0,"term_taxonomy_id":22573,"taxonomy":"post_tag","description":"","parent":0,"count":16,"filter":"raw"}]; _mmunch['postAuthor'] = {"name":"","ID":""};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="42586" async></script><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://tbrnewsmedia.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://tbrnewsmedia.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    

var td_blocks = []; //here we store all the items for the current page

//td_block class - each ajax block uses a object of this class for requests
function td_block() {
    this.id = '';
    this.block_type = 1; //block type id (1-234 etc)
    this.atts = '';
    this.td_cur_cat = '';
    this.td_column_number = '';
    this.td_current_page = 1; //
    this.post_count = 0; //from wp
    this.found_posts = 0; //from wp
    this.max_num_pages = 0; //from wp
    this.is_ajax_running = false;
    this.header_color = '';
    this.ajax_pagination_infinite_stop = ''; //show load more at page x
}

    
var td_ad_background_click_link="";
var td_ad_background_click_target="";
var td_ajax_url="https://tbrnewsmedia.com/wp-admin/admin-ajax.php";
var td_get_template_directory_uri="https://tbrnewsmedia.com/wp-content/themes/Newspaper";
var tds_snap_menu="";
var tds_header_style="";
var tds_mobile_swipe="";
var td_search_url="https://tbrnewsmedia.com/search/";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top="0";
var tds_theme_color_site_wide="#4db2ec";
</script>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-161968053-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-161968053-1');
</script><link rel="stylesheet" href="https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/images/style/output.css?262" type="text/css" />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
<script async src='/cdn-cgi/challenge-platform/h/g/scripts/invisible.js'></script></head>

<body data-rsssl=1 class="post-template-default single single-post postid-136336 single-format-standard td-full-layout editorial-the-mask-returns wpb-js-composer js-comp-ver-4.12 vc_responsive">


<div id="outer-wrap">

    <div id="td-mobile-nav" class="td-transition-content-and-menu">
    <!-- mobile menu close -->
    <div class="td-mobile-close">
        <a href="#">CLOSE</a>
        <div class="td-nav-triangle"></div>
    </div>

    <div class="td-mobile-content">
        <div class="menu-home-container"><ul id="menu-home" class=""><li id="menu-item-1156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-no-down-arrow menu-item-1156"><a href="https://tbrnewsmedia.com/"><span class="menu_icon td-sp td-sp-ico-home"></span><span class="menu_hidden">Home</span></a></li>
<li id="menu-item-744" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-744"><a href="https://tbrnewsmedia.com/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-753" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-753"><a href="https://tbrnewsmedia.com/village-beacon-record/">The Village Beacon Record</a></li>
	<li id="menu-item-749" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-749"><a href="https://tbrnewsmedia.com/port-times-record/">The Port Times Record</a></li>
	<li id="menu-item-754" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-754"><a href="https://tbrnewsmedia.com/village-times-herald/">The Village Times Herald</a></li>
	<li id="menu-item-751" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-751"><a href="https://tbrnewsmedia.com/times-of-middle-country/">The Times of Middle Country</a></li>
	<li id="menu-item-752" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-752"><a href="https://tbrnewsmedia.com/times-of-smithtown/">The Times of Smithtown</a></li>
	<li id="menu-item-750" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-750"><a href="https://tbrnewsmedia.com/times-of-huntington-northport/">The Times of Huntington-Northport</a></li>
</ul>
</li>
<li id="menu-item-747" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-747"><a href="https://tbrnewsmedia.com/sports/">Sports</a></li>
<li id="menu-item-755" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-755"><a href="https://tbrnewsmedia.com/arts-lifestyles/">Arts &amp; Lifestyles</a></li>
<li id="menu-item-748" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-748"><a href="https://tbrnewsmedia.com/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-72567" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72567"><a href="https://tbrnewsmedia.com/category/opinion/editorials/">Editorials</a></li>
	<li id="menu-item-758" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-758"><a href="https://tbrnewsmedia.com/columns/">Columns</a>
	<ul class="sub-menu">
		<li id="menu-item-1380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1380"><a href="https://tbrnewsmedia.com/between-you-and-me/">Between You and Me</a></li>
		<li id="menu-item-2294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2294"><a href="https://tbrnewsmedia.com/d-none-of-the-above/">D. None of the above</a></li>
		<li id="menu-item-1381" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1381"><a href="https://tbrnewsmedia.com/medical-compass/">Medical Compass</a></li>
		<li id="menu-item-123550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-123550"><a href="https://tbrnewsmedia.com/on-the-line-with-tbr/">On the Line with TBR</a></li>
		<li id="menu-item-1378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1378"><a href="https://tbrnewsmedia.com/power-of-3/">Power of 3</a></li>
		<li id="menu-item-1379" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1379"><a href="https://tbrnewsmedia.com/your-turn/">Your Turn</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-746" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-746"><a href="https://tbrnewsmedia.com/police/">Police</a></li>
<li id="menu-item-761" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-761"><a href="https://tbrnewsmedia.com/community/">Community</a>
<ul class="sub-menu">
	<li id="menu-item-1271" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1271"><a href="https://tbrnewsmedia.com/business/">Business</a></li>
	<li id="menu-item-762" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-762"><a href="https://tbrnewsmedia.com/community/education/">Education</a></li>
	<li id="menu-item-1270" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1270"><a href="https://tbrnewsmedia.com/environment/">Environment</a></li>
	<li id="menu-item-763" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-763"><a href="https://tbrnewsmedia.com/community/government/">Government</a></li>
	<li id="menu-item-1272" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1272"><a href="https://tbrnewsmedia.com/kids/">Kids</a></li>
	<li id="menu-item-745" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-745"><a href="https://tbrnewsmedia.com/obituaries/">Obituaries</a></li>
	<li id="menu-item-55647" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55647"><a href="https://tbrnewsmedia.com/culper/">The Culper Spy Adventure</a></li>
	<li id="menu-item-55651" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55651"><a href="https://www.youtube.com/watch?v=keRqna1fr6k">The Abridged Works of Charles Dickens</a></li>
</ul>
</li>
<li id="menu-item-1882" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1882"><a href="https://tbrnewsmedia.com/classifieds/">Classifieds</a></li>
<li id="menu-item-117399" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-117399"><a href="https://tbrnewsmedia.com/real-estate/">Real Estate</a></li>
<li id="menu-item-928" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-928"><a href="https://tbrnewsmedia.com/epaper/">ePaper</a></li>
</ul></div>    </div>
</div>    <div id="inner-wrap" class="td-transition-content-and-menu">
<div class="td-header-menu-wrap">
    <div class="container">
        <div class="row">
            <div class="span9">
                                <div class="menu-top-container"><ul id="menu-td_demo_top" class="top-header-menu"><li id="menu-item-1492" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-1492"><a title="Send Us a Tip" href="https://tbrnewsmedia.com/send-us-tip/">Send Us a Tip</a></li>
<li id="menu-item-1500" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1500"><a title="Write the Editor" href="https://tbrnewsmedia.com/write-the-editor/">Write the Editor</a></li>
<li id="menu-item-1473" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1473"><a title="Advertising" href="https://tbrnewsmedia.com/advertising/">Advertising</a></li>
<li id="menu-item-34138" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-34138"><a href="https://tbrnewsmedia.com/wp-content/uploads/2021/06/LLCNotice_June2021.pdf">Publishing LLC Notices</a></li>
<li id="menu-item-1729" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1729"><a href="https://tbrnewsmedia.com/subscribe/">Subscribe</a></li>
<li id="menu-item-1474" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1474"><a title="Contact Us" href="https://tbrnewsmedia.com/contact/">Contact Us</a></li>
<li id="menu-item-15145" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-15145"><a href="https://tbrnewsmedia.com/contact/">Call Us: 631-751-7744</a></li>
</ul></div>            </div>

            <div class="span3">
                <div class="menu-login-container"><ul id="menu-login" class="menu"><li id="menu-item-3089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-3089"><a href="https://tbrnewsmedia.com/membership-login/">Login</a></li>
</ul></div>            </div>

        </div>
    </div>
</div>



<!-- graphic logo and ad -->
<div class="td-header-bg">
    <div class="container td-logo-rec-wrap">
        <div class="row">
            <div class="span4 header-logo-wrap" role="banner" itemscope="itemscope" itemtype="https://schema.org/Organization">
                                        <a itemprop="url" href="https://tbrnewsmedia.com"><img width="300" src="https://tbrnewsmedia.com/wp-content/uploads/2020/03/tbr_header_logo.jpg" alt="TBR News Media"/></a>
                        <meta itemprop="name" content="TBR News Media">
                                    </div>
            <div class="span8 td-header-style-1">
                <div class="td-a-rec td-a-rec-id-header "><script data-oio-zone="type=banner&zone=1&align=center&refresh=0">
(function(w,d,e,o,u,s,t){w[o]||(w[o]={},s=d.createElement(e),s.src=u,s.async=1,
t=d.getElementsByTagName(e)[0],t.parentNode.insertBefore(s,t))})(window,document,
"script","oiopub","https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/zones.js");
</script></div>            </div>
        </div>
    </div>
</div>
<!-- header menu -->

<div class="td-menu-placeholder">

    <div class="td-menu-background">
        <div class="container td-menu-wrap">



            <div class="row-fluid td-menu-header">

                <div class="span11">
                                            <div class="mobile-logo-wrap">
                                                                    <a itemprop="url" href="https://tbrnewsmedia.com"><img width="300"  src="https://tbrnewsmedia.com/wp-content/uploads/2020/03/tbr_header_logo.jpg" alt="TBR News Media"/></a>
                                        <meta itemprop="name" content="TBR News Media">
                                                            </div>
                    

                    <div id="td-top-mobile-toggle">
                        <ul class="sf-menu">
                            <li>
                                <a href="#">
                                    <span class="menu_icon td-sp td-sp-ico-menu"></span>
                                </a>
                            </li>
                        </ul>
                    </div>

                    <div id="td-top-menu" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">

                            <div class="menu-home-container"><ul id="menu-home-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-no-down-arrow td-menu-item td-normal-menu menu-item-1156"><a href="https://tbrnewsmedia.com/"><span class="menu_icon td-sp td-sp-ico-home"></span><span class="menu_hidden">Home</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-744"><a href="https://tbrnewsmedia.com/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-753"><a href="https://tbrnewsmedia.com/village-beacon-record/">The Village Beacon Record</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-749"><a href="https://tbrnewsmedia.com/port-times-record/">The Port Times Record</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-754"><a href="https://tbrnewsmedia.com/village-times-herald/">The Village Times Herald</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-751"><a href="https://tbrnewsmedia.com/times-of-middle-country/">The Times of Middle Country</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-752"><a href="https://tbrnewsmedia.com/times-of-smithtown/">The Times of Smithtown</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-750"><a href="https://tbrnewsmedia.com/times-of-huntington-northport/">The Times of Huntington-Northport</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-747"><a href="https://tbrnewsmedia.com/sports/">Sports</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-755"><a href="https://tbrnewsmedia.com/arts-lifestyles/">Arts &amp; Lifestyles</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-748"><a href="https://tbrnewsmedia.com/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72567"><a href="https://tbrnewsmedia.com/category/opinion/editorials/">Editorials</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-758"><a href="https://tbrnewsmedia.com/columns/">Columns</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1380"><a href="https://tbrnewsmedia.com/between-you-and-me/">Between You and Me</a></li>
		<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2294"><a href="https://tbrnewsmedia.com/d-none-of-the-above/">D. None of the above</a></li>
		<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1381"><a href="https://tbrnewsmedia.com/medical-compass/">Medical Compass</a></li>
		<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-123550"><a href="https://tbrnewsmedia.com/on-the-line-with-tbr/">On the Line with TBR</a></li>
		<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1378"><a href="https://tbrnewsmedia.com/power-of-3/">Power of 3</a></li>
		<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1379"><a href="https://tbrnewsmedia.com/your-turn/">Your Turn</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-746"><a href="https://tbrnewsmedia.com/police/">Police</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-761"><a href="https://tbrnewsmedia.com/community/">Community</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1271"><a href="https://tbrnewsmedia.com/business/">Business</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-762"><a href="https://tbrnewsmedia.com/community/education/">Education</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1270"><a href="https://tbrnewsmedia.com/environment/">Environment</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-763"><a href="https://tbrnewsmedia.com/community/government/">Government</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1272"><a href="https://tbrnewsmedia.com/kids/">Kids</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-745"><a href="https://tbrnewsmedia.com/obituaries/">Obituaries</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-55647"><a href="https://tbrnewsmedia.com/culper/">The Culper Spy Adventure</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-55651"><a href="https://www.youtube.com/watch?v=keRqna1fr6k">The Abridged Works of Charles Dickens</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1882"><a href="https://tbrnewsmedia.com/classifieds/">Classifieds</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-117399"><a href="https://tbrnewsmedia.com/real-estate/">Real Estate</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-928"><a href="https://tbrnewsmedia.com/epaper/">ePaper</a></li>
</ul></div>                    </div>



                </div>

                <div class="span1" id="td-top-search">
                    <!-- Search -->
                    <div class="header-search-wrap">
                        <div class="dropdown header-search">
                            <a id="search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><span class="td-sp td-sp-ico-search"></span></a>
                            <div class="dropdown-menu" aria-labelledby="search-button">
                                <form role="search" method="get" class="td-search-form" action="https://tbrnewsmedia.com/">
                                    <div class="td-head-form-search-wrap">
                                        <input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                                    </div>
                                </form>
                                <div id="td-aj-search"></div>
                            </div>
                        </div>
                    </div>
                </div>


            </div> <!-- /.row-fluid -->
        </div> <!-- /.td-menu-wrap -->
    </div> <!-- /.td-menu-background -->
</div> <!-- /.td-menu-placeholder -->
        <div class="container td-page-wrap">
            <div class="row">
                <div class="span12">
                    <div class="td-grid-wrap">
                        <div class="container-fluid">
                            <div class="row-fluid ">
                        <div class="span8 column_container td-post-content" role="main" itemprop="mainContentOfPage">
                    <div class="entry-crumbs"><span itemscope itemtype="https://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="https://tbrnewsmedia.com"><span itemprop="title">Home</span></a></span> <span class="td-sp td-sp-breadcrumb-arrow td-bread-sep"></span> <span itemscope itemtype="https://data-vocabulary.org/Breadcrumb"><a title="View all posts in Columns" class="entry-crumb" itemprop="url" href="https://tbrnewsmedia.com/category/columns/"><span itemprop="title">Columns</span></a></span> <span class="td-sp td-sp-breadcrumb-arrow td-bread-sep"></span> <span itemscope itemtype="https://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Editorial: The mask returns">Editorial: The mask returns</span></div>
        <article id="post-136336" class="post-136336 post type-post status-publish format-standard has-post-thumbnail hentry category-columns category-editorials category-health category-opinion category-port-times-record category-times-of-huntington-northport category-times-of-middle-country category-times-of-smithtown category-village-beacon-record category-village-times-herald tag-covid-19 tag-editorial tag-masks" itemscope itemtype="https://schema.org/Article">

        <header>

            <h1 itemprop="name" class="entry-title">Editorial: The mask returns</h1>
            <div class="meta-info">
                <ul class="td-category"><li class="entry-category"><a  href="https://tbrnewsmedia.com/category/columns/">Columns</a></li><li class="entry-category"><a  href="https://tbrnewsmedia.com/category/opinion/">Opinion</a></li><li class="entry-category"><a  href="https://tbrnewsmedia.com/category/opinion/editorials/">Editorials</a></li><li class="entry-category"><a  href="https://tbrnewsmedia.com/category/health/">Health</a></li><li class="entry-category"><a  href="https://tbrnewsmedia.com/category/port-times-record/">Port Times Record</a></li><li class="entry-category"><a  href="https://tbrnewsmedia.com/category/times-of-huntington-northport/">Times of Huntington-Northport</a></li><li class="entry-category"><a  href="https://tbrnewsmedia.com/category/times-of-middle-country/">Times of Middle Country</a></li><li class="entry-category"><a  href="https://tbrnewsmedia.com/category/times-of-smithtown/">Times of Smithtown</a></li><li class="entry-category"><a  href="https://tbrnewsmedia.com/category/village-beacon-record/">Village Beacon Record</a></li><li class="entry-category"><a  href="https://tbrnewsmedia.com/category/village-times-herald/">Village Times Herald</a></li></ul>                <div class="td-clear-author"></div><span class="td-block-author">by <a itemprop="author" href="https://tbrnewsmedia.com/author/tbrstaff/">TBR Staff</a> - </span><meta itemprop="interactionCount" content="UserComments:0"/>                <time  itemprop="dateCreated" class="entry-date updated" datetime="2021-12-16T15:10:43+00:00" >December 16, 2021</time><meta itemprop="interactionCount" content="UserComments:0"/>                <div class="entry-comments-views"><span class="td-sp td-sp-ico-comments td-fake-click" data-fake-click="https://tbrnewsmedia.com/editorial-the-mask-returns/#respond"></span>0 <span class="td-sp td-sp-ico-view"></span><span class="td-nr-views-136336">5</span></div>            </div>
        </header>


        

        <div class="td-post-featured-image"><figure><a href="https://tbrnewsmedia.com/wp-content/uploads/2021/12/editorial-masks_stock-photo-e1639685355303.jpg" data-caption="METRO photo"><img width="700" height="443" itemprop="image" class="entry-thumb td-modal-image" src="https://tbrnewsmedia.com/wp-content/uploads/2021/12/editorial-masks_stock-photo-e1639685355303-700x443.jpg" alt="" title="editorial-masks_stock-photo"/></a><figcaption class="wp-caption-text">METRO photo</figcaption></figure></div>
        <div class="td-post-text-content">
            <div class='mailmunch-forms-before-post' style='display: none !important;'></div><p>It’s no surprise that face mask use is mandated once again when visiting or working in a store or venue in the state of New York. Gov. Kathy Hochul (D) said earlier this year if the COVID-19 infection rate kept climbing, the mandatory health protocol would be needed again.</p>
<p>Until Jan. 15, 2022, when the state will reassess, unless an establishment has a vaccine requirement, a mask must be worn by everyone 2 years old and up. The governor announced the statewide mandate that began Monday, Dec. 13, during a press conference last Friday. In addition, businesses that do not comply can face fines up<br />
to $1,000.</p>
<p>According to a recent article in The New York Times, the state’s infection rate last Saturday reflected a 51% jump over 14 days. With more than a 7% seven-day infection rate in Suffolk County, Hochul’s new mandate seems more than appropriate for our communities.</p>
<p>While some people still have been wearing masks either because they aren’t vaccinated or as an extra precaution, many have not since former Gov. Andrew Cuomo (D) lifted the initial mask mandate in the state.</p>
<p>The news can be frustrating for those who are vaccinated and even received the booster shot. However, Americans have known since the virus first reached our shores that it would take a while to figure out how to lessen transmission, especially since a virus can mutate. With no practice 100% effective — and some people resisting not only wearing masks but getting the vaccine — the virus has continued infecting people and new variants have developed, such as Delta and Omicron. While medical researchers are still trying to understand the virus, why not take extra precautions? Even if they are not guaranteed to stop transmission, they can lessen the chances of spreading the virus.</p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div>
<p>While face masks can be uncomfortable at times, the protective gear acts as a barrier to protect the wearer from droplets released in the air when someone coughs or sneezes. It also traps the wearer’s respiratory droplets. If someone is sick and they are wearing a mask, they are less likely to give someone else the virus.</p>
<p>When Cuomo issued mandatory business shutdowns in the early days of the pandemic, New Yorkers debated if this was the right approach. A good percentage of people thought it would be the demise of many businesses. Fortunately, many business owners were able to swim with the tide and come up with innovative solutions such as curbside service and selling merchandise on social media if they didn’t have a website.</p>
<p>Now more than ever, local businesses need our support as many of them cannot make it through another round of shutdowns. So, let’s mask up before stepping inside a favorite store, restaurant or theater so that we can keep these places not only open but give them a chance to thrive.</p>
<p>After all, this is the season of goodwill.</p>
<div class='mailmunch-forms-after-post' style='display: none !important;'></div>        </div>


        <div class="clearfix"></div>

        <footer>
                                                
            <div class="td-social-sharing">
                <div class="td-tags-and-social-wrapper-box "> <ul class="td-tags clearfix"><li><span class="td-tag-black">TAGS</span></li><li><a href="https://tbrnewsmedia.com/tag/covid-19/">Covid 19</a></li><li><a href="https://tbrnewsmedia.com/tag/editorial/">editorial</a></li><li><a href="https://tbrnewsmedia.com/tag/masks/">Masks</a></li></ul></div>
                <div class="td-tags-and-social-wrapper-box td-tags-and-social-wrapper-box-bottom-line">
                    <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Editorial%3A+The+mask+returns&url=https%3A%2F%2Ftbrnewsmedia.com%2Feditorial-the-mask-returns%2F&via=TBR+News+Media" onclick="if(!document.getElementById('td_social_networks_buttons')){window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;}" ><div class="td-sp td-sp-share-twitter"></div><div class="td-social-but-text">Twitter</div></a>
                    <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ftbrnewsmedia.com%2Feditorial-the-mask-returns%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><div class="td-sp td-sp-share-facebook"></div><div class="td-social-but-text">Facebook</div></a>
                    <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://tbrnewsmedia.com/editorial-the-mask-returns/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><div class="td-sp td-sp-share-google"></div><div class="td-social-but-text">Google +</div></a>
                    <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://tbrnewsmedia.com/editorial-the-mask-returns/&amp;media=https://tbrnewsmedia.com/wp-content/uploads/2021/12/editorial-masks_stock-photo-e1639685355303.jpg" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><div class="td-sp td-sp-share-pinterest"></div><div class="td-social-but-text">Pinterest</div></a>
                </div></div>                        <div class="wpb_row row-fluid next-prev"><div class="span6 prev-post"><div><img width="6" class="td-retina" src="https://tbrnewsmedia.com/wp-content/themes/Newspaper/images/icons/similar-left.png" alt=""/>Previous article</div><a href="https://tbrnewsmedia.com/d-none-of-the-above-walks-to-remember-on-cold-nights-in-december/">D. None of the Above: Walks to remember on cold nights in December</a></div></div>            <div class="author-box-wrap"><a href="https://tbrnewsmedia.com/author/tbrstaff/"><img src="https://tbrnewsmedia.com/wp-content/uploads/2017/08/tbr_boat-150x150.jpg" width="106" height="106" alt="TBR Staff" class="avatar avatar-106 wp-user-avatar wp-user-avatar-106 alignnone photo" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://tbrnewsmedia.com/author/tbrstaff/">TBR Staff</a></span></div><div>TBR News Media covers everything happening on the North Shore of Suffolk County from Cold Spring Harbor to Wading River.</div><div class="td-author-social"><span class="td-social-icon-wrap"><a rel="nofollow"  href="https://www.facebook.com/TBRNewspapers"><span class="td-social-s4-16 td-s-s-16-facebook"></span></a></span><span class="td-social-icon-wrap"><a rel="nofollow"  href="https://www.instagram.com/tbrnewspapers/"><span class="td-social-s4-16 td-s-s-16-instagram"></span></a></span><span class="td-social-icon-wrap"><a rel="nofollow"  href="https://twitter.com/TBRNewspapers"><span class="td-social-s4-16 td-s-s-16-twitter"></span></a></span></div><div class="clearfix"></div></div></div>

            <meta itemprop="author" content = "TBR Staff">        </footer>

    </article> <!-- /.post -->

    <div class="art-img-text-down similar-articles"><h4 class="block-title"><span>SIMILAR ARTICLES</span></h4>

	<div class="wpb_row row-fluid">

	<div class="span6">

        <div class="td_mod6 td_mod_wrap " itemscope itemtype="https://schema.org/Article">
        <div class="thumb-wrap"><a href="https://tbrnewsmedia.com/d-none-of-the-above-walks-to-remember-on-cold-nights-in-december/" rel="bookmark" title="D. None of the Above: Walks to remember on cold nights in December"><img width="326" height="159" itemprop="image" class="entry-thumb" src="https://tbrnewsmedia.com/wp-content/uploads/2021/12/dog-2362683_1920-326x159.jpg" alt="" title="D. None of the Above: Walks to remember on cold nights in December"/></a></div>        <h3 itemprop="name" class="entry-title"><a itemprop="url" href="https://tbrnewsmedia.com/d-none-of-the-above-walks-to-remember-on-cold-nights-in-december/" rel="bookmark" title="D. None of the Above: Walks to remember on cold nights in December">D. None of the Above: Walks to remember on cold nights in December</a></h3>
        <div class="meta-info">
                        <time  itemprop="dateCreated" class="entry-date updated" datetime="2021-12-16T15:00:51+00:00" >December 16, 2021</time><meta itemprop="interactionCount" content="UserComments:0"/>            <div class="entry-comments-views"><span class="td-sp td-sp-ico-comments td-fake-click" data-fake-click="https://tbrnewsmedia.com/d-none-of-the-above-walks-to-remember-on-cold-nights-in-december/#respond"></span>0 <span class="td-sp td-sp-ico-view"></span><span class="td-nr-views-136334">6</span></div>        </div>


        <meta itemprop="author" content = "Daniel Dunaief">        </div>

        
	</div> <!-- ./span6 -->

	<div class="span6">

        <div class="td_mod6 td_mod_wrap " itemscope itemtype="https://schema.org/Article">
        <div class="thumb-wrap"><a href="https://tbrnewsmedia.com/losquadro-discusses-local-roadways-at-civic-meeting/" rel="bookmark" title="Losquadro discusses local roadways at civic meeting"><img width="326" height="159" itemprop="image" class="entry-thumb" src="https://tbrnewsmedia.com/wp-content/uploads/2021/12/Herb-Mones_Dan-Losquadro_120621_3V-Civic-meeting-scaled-e1639603842324-326x159.jpg" alt="" title="Losquadro discusses local roadways at civic meeting"/></a></div>        <h3 itemprop="name" class="entry-title"><a itemprop="url" href="https://tbrnewsmedia.com/losquadro-discusses-local-roadways-at-civic-meeting/" rel="bookmark" title="Losquadro discusses local roadways at civic meeting">Losquadro discusses local roadways at civic meeting</a></h3>
        <div class="meta-info">
                        <time  itemprop="dateCreated" class="entry-date updated" datetime="2021-12-16T15:00:29+00:00" >December 16, 2021</time><meta itemprop="interactionCount" content="UserComments:0"/>            <div class="entry-comments-views"><span class="td-sp td-sp-ico-comments td-fake-click" data-fake-click="https://tbrnewsmedia.com/losquadro-discusses-local-roadways-at-civic-meeting/#respond"></span>0 <span class="td-sp td-sp-ico-view"></span><span class="td-nr-views-136308">6</span></div>        </div>


        <meta itemprop="author" content = "Rita J. Egan">        </div>

        
	</div> <!-- ./span6 --></div><!--./row-fluid--></div>
                        <div class="comments" id="comments">
                                                                                                <div class="comments-title-wrap">
                                                                                <h4 class="block-title"><span>NO COMMENTS</span></h4>
                                    </div>

                                                                                            	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/editorial-the-mask-returns/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://tbrnewsmedia.com/tbr-press/?redirect_to=https%3A%2F%2Ftbrnewsmedia.com%2Feditorial-the-mask-returns%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	                                                    </div> <!-- /.content -->


                </div>
                <div class="span4 column_container td-post-sidebar" role="complementary" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
                    <aside class="widget widget_text">			<div class="textwidget"><p><script type="text/javascript" src="https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/js.php#type=banner&#038;align=center&#038;zone=2"></script></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><p><a href="https://www.facebook.com/TBRNewsMedia"><br />
<img loading="lazy" src="https://tbrnewsmedia.com/wp-content/uploads/2020/08/facebook_banner-min.png" alt="Find Us On Facebook" width="336" height="108" border="0" /><br />
</a></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><p><a href="https://issuu.com/tbrmedia/docs/tfg_112521w"><br />
<img src="https://tbrnewsmedia.com/wp-content/uploads/2021/11/tfg.112521.banner.jpg" alt="Time for Giving - Free Gift Catalog" width="336" height=““154”” border="0" />Click here to see the entire catalog!<br />
</a></p>
<div>
<marquee behavior="scroll" direction="up" onmouseover="this.stop();" onmouseout="this.start();" style="height:250px;" ></p>
<p>Kids under 12</p>
<p>STONY BROOK CHRISTIAN ASSEMBLY<br />
EAST SETAUKET<br />
Meet the crazy professor and travel back in time at the Stony Brook Christian Assembly “Living Nativity.”  Make this part of your family tradition.  Sat., Dec. 4;<br />
Sun., Dec.5; Fri., Dec.10 and Sat. Dec.11.<br />
Performances are from 6 – 9 each night.<br />
stonybrookchristian.com </p>
<p>STONY BROOK FIRE DEPARTMENT<br />
STONY BROOK<br />
This holiday season, be sure your home is equipped with smoke and CO detectors, 9 volt batteries, flashlights, escape ladder, battery operated radio, hurricane preparedness kit and a residential sprinkler system.</p>
<p>THEATRE THREE<br />
PORT JEFFERSON<br />
Every child would love a gift certificate to any Children’s Performance. Consider bringing the entire family to share in the fun.<br />
theatrethree.com</p>
<p>Teens</p>
<p>ECOLIN JEWELERS<br />
PORT JEFFERSON<br />
Handmade sterling silver initial, monogram or nameplate necklaces starting at $100.00.<br />
ecolin.com</p>
<p>SEA CREATIONS<br />
PORT JEFFERSON<br />
Little Words Project Bracelets.  Wear them to promote self-love and confidence…You’re Great!<br />
seacreations.com</p>
<p>SETAUKET KITCHEN AND BATH<br />
SETAUKET<br />
Inspire your student with a new desk, hutch or shelves designed with their needs in mind.<br />
setauketkitchens.com</p>
<p>STONY BROOK FIRE DEPARTMENT<br />
STONY BROOK<br />
This holiday season, be sure your home is equipped with smoke and CO detectors, 9 volt batteries, flashlights, escape ladder, battery operated radio, hurricane preparedness kit and a residential sprinkler system.</p>
<p>New parents</p>
<p>ECOLIN JEWELERS<br />
PORT JEFFERSON<br />
Celebrate the new addition to your family with a birthstone pendant for mom to wear now and baby to wear later. Or, select sterling silver feeding spoons, brush and comb sets, photo frames or baby cups&#8230;the heirlooms of tomorrow.<br />
ecolin.com</p>
<p>MOLONEY FAMILY FUNERAL HOMES<br />
PORT JEFF STA.<br />
Our family is there for your family year round. Happy Holidays!<br />
moloneyfh.com</p>
<p>STALLER CENTER<br />
STONY BROOK<br />
A gift card for a live performance or a pass to the Stony Brook Film Festival is a gift that will be welcomed by any new parent. Visit our website or box office for your purchase.<br />
stallercenter.com</p>
<p>SETAUKET GOURMET DELICATESSEN &#038; CATERERS<br />
EAST SETAUKET<br />
Give the gift of homestyle meals without the stress of planning and cooking. Delicious dinners, treats and gift certificates!<br />
setauketgourmet.com</p>
<p>STONY BROOK FIRE DEPARTMENT<br />
STONY BROOK<br />
This holiday season, be sure your home is equipped with smoke and CO detectors, 9 volt batteries, flashlights, escape ladder, battery operated radio, hurricane preparedness kit and a residential sprinkler system.</p>
<p>WIGGS OPTICIANS<br />
STONY BROOK<br />
New parents will love the convenience of the new Smart Ray-Ban Sunglasses. With a tap on your sunglasses you can record live videos, take photo snapshots, listen to music, take a phone call and much more. Order a pair today.<br />
wiggsopticians.com</p>
<p>Grandparents</p>
<p>CHARIOT COLLISION CENTER<br />
EAST SETAUKET<br />
A gift certificate for a complete auto detailing, inside and out.<br />
chariotautocollision.com</p>
<p>COUNTRY HOUSE RESTAURANT<br />
STONY BROOK<br />
Grandparents anxiously await and look forward to their annual holiday gift certificate to their favorite restaurant, The Country House Restaurant. Don’t disappoint them.<br />
countryhouserestaurant.com</p>
<p>ECOLIN JEWELERS<br />
PORT JEFFERSON<br />
Make it easy to show off the grandkids&#8230;sterling silver or 14k gold lockets for their photos OR give a gift certificate to be used for restoration or repair of family heirlooms&#8230;ensure that sentimental pieces can be worn safely and comfortably for years to come.<br />
ecolin.com</p>
<p>HEARING &#038; TINNITUS MANAGEMENT, LLC<br />
STONY BROOK<br />
Stay connected this holiday season. Don’t let hearing loss limit you. Be proactive and schedule a hearing evaluation today.<br />
LIAudiology.com</p>
<p>JEFFERSON’S FERRY<br />
SOUTH SETAUKET<br />
Schedule your tour today for Jefferson’s Ferry Life Plan Community with the benefits of Life Care. Get the care you need, if you need it.<br />
jeffersonsferry.org</p>
<p>JOS. M. TROFFA<br />
EAST SETAUKET<br />
No holiday is complete without the magic, warmth and beauty of a fireplace in your home. Joseph <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="c296b0ada4a4a382b1b7abb6a7">[email&#160;protected]</a> 9 has everything to light up your holidays and backyard fun through the seasons. Your full service masonry and landscape supply center.<br />
troffa.com</p>
<p>MOLONEY FAMILY FUNERAL HOMES<br />
PORT JEFFERSON STATION<br />
Our family is there for your family year round. Happy Holidays!<br />
moloneyfh.com</p>
<p>O.B. DAVIS FUNERAL HOMES<br />
PORT JEFFERSON STATION, MILLER PLACE, CENTEREACH<br />
Planning your final arrangements in advance is one of the greatest gifts you can give to your family. Visit our website to learn more about our Dignity Memorial Personal Planning Guide.<br />
dignitymemorial.com</p>
<p>PJ CINEMAS<br />
PORT JEFFERSON STATION<br />
PJ Cinemas, where seniors, kids and matinees are just $6.50. Handicap accessible. Come see a movie today!<br />
mypjcinemas.com</p>
<p>SEISKAYA BALLET<br />
STONY BROOK<br />
Who deserves that special treat? The grandparents, of course! They’ll enjoy a tantalizing evening of Seiskaya Ballet’s production of The Nutcracker at the Staller Center. Visit Seiskaya.com for additional information.<br />
seiskaya.com</p>
<p>SETAUKET KITCHEN AND BATH<br />
SETAUKET<br />
Indulge yourself with a delightful new master bath designed with both of your needs and wishes in mind.<br />
setauketkitchens.com</p>
<p>STALLER CENTER<br />
STONY BROOK<br />
Kick off the holiday season with tickets to see the Stephanie Quayle: Country Christmas Show on December 11th at 8 pm. Visit our website to purchase tickets.<br />
stallercenter.com</p>
<p>STONY BROOK FIRE DEPARTMENT<br />
STONY BROOK<br />
This holiday season, be sure your home is equipped with smoke and CO detectors, 9 volt batteries, flashlights, escape ladder, battery operated radio, hurricane preparedness kit and a residential sprinkler system.</p>
<p>SUFFOLK VASCULAR &#038; VEIN CENTERS<br />
PORT JEFF STA., HAUPPAUGE, RIVERHEAD<br />
During the holidays, we spend more time on our feet. Do you suffer from leg pain or have varicose veins? We can help. Contact us at one of our three locations.<br />
suffolkvascular.com</p>
<p>THEATRE THREE<br />
PORT JEFFERSON<br />
Celebrate the season with Long Island’s own holiday tradition. Join us for our 37th annual production of the immortal classic  &#8211;  A Christmas Carol with all of its thrills, music, joy and spirit. Performances through December 26th.<br />
theatrethree.com</p>
<p>YOUR CBD STORE<br />
PORT JEFFERSON STATION<br />
Grandparents are a gift. Spoil them with the best CBD products for their Health and Wellness. Our wellness bundle includes our award winning Topical and Assorted CBD Candies. Bundles start at $125.<br />
cbdrx4u.com</p>
<p>Couples</p>
<p>ANDREW MASTRONARDI, DMD<br />
PORT JEFFERSON STATION<br />
Whiter teeth for the holidays! Holiday special:  take home trays &#8211; $250. In-office whitening &#8211; $250. Gift certificates available.<br />
mastronardidental.com</p>
<p>ARCHDEACON AGENCY<br />
LAKE GROVE<br />
Don’t let that precious ring go uninsured. Call or stop by our new Lake Grove location for a free quote.<br />
archdeaconagency.com</p>
<p>CHARIOT COLLISION CENTER<br />
EAST SETAUKET<br />
A gift certificate for a complete auto detailing, inside and out.<br />
chariotautocollision.com</p>
<p>DOUGLAS ELLIMAN<br />
EAST SETAUKET<br />
The Real Estate Market in our area is thriving and Douglas Elliman is here to help you safely maximize your most valuable asset. Call Team East Setauket today and ask us how we can help you join our growing list of sold homes.<br />
elliman.com</p>
<p>JEFFERSON’S FERRY<br />
SOUTH SETAUKET<br />
Plan for the future. Schedule a tour today to learn about our variety of living options.<br />
jeffersonsferry.org</p>
<p>JOS. M. TROFFA<br />
EAST SETAUKET<br />
No holiday is complete without the magic, warmth and beauty of a fireplace in your home. Joseph <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="0551776a6363644576706c7160">[email&#160;protected]</a> 9 has everything to light up your holidays and backyard fun through the seasons. Your full service masonry and landscape supply center.<br />
troffa.com</p>
<p>LESSING’S RESTAURANTS<br />
VARIOUS LOCATIONS<br />
Lessing’s GIFT CARDS! Now through December 24th with every $100 gift card purchase, receive a complimentary $20 gift card from us (valid in all Lessing’s Restaurants).<br />
lessings.com</p>
<p>SETAUKET KITCHEN AND BATH<br />
SETAUKET<br />
Indulge yourself with a delightful new master bath designed with both of your needs and wishes in mind.<br />
setauketkitchens.com</p>
<p>STALLER CENTER<br />
STONY BROOK<br />
Passes to the Stony Brook Film Festival make an awesome gift for date night!! Visit our website for details.<br />
stallercenter.com</p>
<p>STONY BROOK FIRE DEPARTMENT<br />
STONY BROOK<br />
This holiday season, be sure your home is equipped with smoke and CO detectors, 9 volt batteries, flashlights, escape ladder, battery operated radio, hurricane preparedness kit and a residential sprinkler system.</p>
<p>SUFFOLK VASCULAR &#038; VEIN CENTERS<br />
PORT JEFF STA., HAUPPAUGE, RIVERHEAD<br />
During the holidays, we spend more time on our feet. Do you suffer from leg pain or have varicose veins? We can help. Contact us at one of our three locations.<br />
suffolkvascular.com</p>
<p>THEATRE THREE<br />
PORT JEFFERSON<br />
Celebrate the season with Long Island’s own holiday tradition. Join us for our 37th annual production of the immortal classic – A Christmas Carol with all of its thrills, music, joy and spirit. Performances through December 26th.<br />
theatrethree.com</p>
<p>WESTHAMPTON BEACH PERFORMING ARTS CENTER<br />
WESTHAMPTON BEACH<br />
Date night in the Hamptons. Tickets to see all-star rock, comedy and cabaret lineups in 2022. Visit our website for additional info.<br />
WHBPAC. org</p>
<p>Colleagues &#038; Corporate</p>
<p>BON BONS CHOCOLATIER<br />
HUNTINGTON VILLAGE<br />
A box of hand-crafted Chocolates from Bon Bons makes the perfect gift for your boss or colleague. You can make a selection or pick up our pre-assorted boxes in a variety of sizes. Favor boxes can be ordered for your holiday party. A range of corporate gifts, baskets or gift certificates are available.<br />
bonbonschocolatier.com</p>
<p>EAST WIND<br />
WADING RIVER<br />
A Gift of a Getaway is what you can get with a gift card from East Wind. Long Island’s premier North Fork Destination, elegant wedding venue, luxury hotel, spa and dining.<br />
eastwindlongisland.com</p>
<p>JERSEY MIKE’S SUBS<br />
STONY BROOK, HAUPPAUGE, PORT JEFF STATION<br />
Thank your staff and corporate clients with Jersey Mike’s catering. Choose from our subs in a box or personal boxed lunches and remember our cookie and brownie trays for dessert.<br />
jerseymikes.com</p>
<p>KUNZ GREENHOUSEES<br />
PORT JEFFERSON STATION<br />
Poinsettias grown in our own greenhouses. Choose from a selection of sizes, color and varieties. Featuring our Princettia in pink or white. We also carry a large selection of plants perfect for offices or home.<br />
kunzgreenhouses.com</p>
<p>MARIO’S RESTAURANT &#038; BAR<br />
EAST SETAUKET<br />
Looking for a special way to thank your staff and let them know you appreciate them? Have lunch catered at your office or in one of our private party rooms.<br />
mariossetauket.com</p>
<p>SETAUKET GOURMET DELICATESSEN &#038; CATERERS<br />
EAST SETAUKET<br />
Sending a thank you to an office or small group of people? Try our holiday shaped party hero. Complete with a salad and dessert tray!<br />
setauketgourmet.com</p>
<p>SETAUKET KITCHEN AND BATH<br />
SETAUKET<br />
Cheer and charm your friends and colleagues by investing in a handsome new bar to entertain at home.<br />
setauketkitchens.com</p>
<p>STALLER CENTER<br />
STONY BROOK<br />
Tickets to a performance at the Staller Center make the perfect gift for those special colleagues. From theater, musical acts, dance, comedy and film the Staller Center offers it all.<br />
stallercenter.com</p>
<p>STONY BROOK CHOCOLATE<br />
STONY BROOK<br />
Customizable and personalized gifts, gift towers and baskets of all sizes. $10 &#8211; $150<br />
stonybrookchocolate.com</p>
<p>STONY BROOK FIRE DEPARTMENT<br />
STONY BROOK<br />
This holiday season, be sure your home is equipped with smoke and CO detectors, 9 volt batteries, flashlights, escape ladder, battery operated radio, hurricane preparedness kit and a residential sprinkler system.</p>
<p>SUFFOLK VASCULAR &#038; VEIN CENTER CENTERS<br />
PORT JEFF STA., HAUPPAUGE, RIVERHEAD<br />
During the holidays, we spend more time on our feet. Do you suffer from leg pain or have varicose veins? We can help. Contact us at one of our three locations.<br />
suffolkvascular.com</p>
<p>THREE VILLAGE HISTORICAL SOCIETY<br />
SETAUKET<br />
Usher in the holiday season with the time honored tradition of the Candlelight House Tour. Tour 4 beautifully decorated homes and other buildings throughout the Stony Brook area. $40 -$75<br />
tvhs.org</p>
<p>WESTHAMPTON BEACH PERFORMING ARTS CENTER<br />
WESTHAMPTON BEACH<br />
Share the magic of the arts this holiday season with a gift card to the WHBPAC.  Visit our website for shows, classes and dates.<br />
whbpac.org</p>
<p>Grab bags, stocking stuffers</p>
<p>BON BONS CHOCOLATIER<br />
HUNTINGTON VILLAGE<br />
Who doesn’t like a $20 gift certificate from Bon Bons for their Secret Santa? We also offer lots of small, sweet things for your stockings…. favor boxes of chocolates, toys, candy, novelty socks, chocolate covered pretzels and more!<br />
bonbonschocolatier.com</p>
<p>CHRISTINA’S HANDBAGS<br />
PORT JEFFERSON<br />
Stuff stockings with something that matters &#8211; accessories from Christina’s Handbags in Port Jefferson on Main. 20 &#8211; 50% off everything &#8211; our gift to you.<br />
christinasfashionhandbags.com </p>
<p>DISCOVER LONG ISLAND<br />
HAUPPAUGE<br />
Long Island Lighthouse Socks. Show your Long Island pride with these fun stocking stuffers that are a must have for every local. $15<br />
shop.discoverlongisland.com</p>
<p>HATCH<br />
HUNTINGTON<br />
Spread pancake love!  With every $25 gift card purchase, score a free order of pancakes (now through December 24th. In store promotion only.)<br />
hatchbrunch.com</p>
<p>JERSEY MIKE’S SUBS<br />
STONY BROOK, HAUPPAUGE, PORT JEFF STATION<br />
Remember all the special people in your life with a Jersey Mike’s gift card.<br />
jerseymikes.com</p>
<p>MARIO’S RESTAURANT &#038; BAR<br />
EAST SETAUKET<br />
Anyone would love to receive a gift certificate to Mario’s Restaurant &#038; Bar. Available in all denominations.<br />
mariossetauket.com</p>
<p>THE REBOLI CENTER FOR ART AND HISTORY<br />
STONY BROOK<br />
Joseph Reboli, 13 Month 2022 Calendars featuring a new Reboli Artwork each month! A lovely gift for all ages. Locally made and under $16.<br />
rebolicenter.org</p>
<p>ST. JOHNLAND NURSING CENTER<br />
KINGS PARK<br />
Coming Fall 2022 &#8211; St. Johnland Assisted Living Facility.  Schedule your tour today!  Visit our website for further information.<br />
Stjohnland.org</p>
<p>THE SHOPPES AT EAST WIND<br />
WADING RIVER<br />
Shop Small Shop Local. You can find many gifts for the entire family at the Shoppes. Visit with Santa and ride Rudolph on the Carousel. Open daily.<br />
eastwindlongisland.com/shoppes </p>
<p>STALLER CENTER<br />
STONY BROOK<br />
A gift card to the Staller Center is a must for every stocking stuffer! Visit our website to purchase your card.<br />
stallercenter.com</p>
<p>STONY BROOK CHOCOLATE<br />
STONY BROOK<br />
$4 and up, a large variety of treats and sweets for any gift giving need.<br />
stonybrookchocolate.com</p>
<p>THREE VILLAGE HISTORICAL SOCIETY<br />
SETAUKET<br />
Enjoy an exclusive scented candle benefitting the Candlelight House Tour or decorate your tree with our custom house ornament! Stop in for more great gifts!  $5 -$50<br />
tvhs.org</p>
<p>WESTHAMPTON BEACH PERFORMING ARTS CENTER<br />
WESTHAMPTON BEACH<br />
A gift card to the WHBPAC will make a great stocking stuffer or grab bag gift for all ages. Visit our website for upcoming shows and classes.<br />
whbpac.org</p>
<p>Extravagances</p>
<p>ECOLIN JEWELERS<br />
PORT JEFFERSON<br />
Dazzling diamond stud earrings…because the tree shouldn’t be the only thing you decorate this year.<br />
www.ecolin.com</p>
<p>ECOLIN JEWELERS<br />
PORT JEFFERSON<br />
Platinum and diamond engagement ring…make this holiday one to remember now and to mark the beginning of your new life together.<br />
ecolin.com</p>
<p>STALLER CENTER<br />
STONY BROOK<br />
Gala 2022 – Emanuel Ax, Leonidas Kavakos and Yo-Yo Ma will headline the 2022 Staller Center Gala. Tickets to this extravaganza make the perfect gift for those hard to shop for relatives.<br />
stallercenter.com/gala</p>
<p>For the home</p>
<p>ARCHDEACON AGENCY<br />
LAKE GROVE<br />
Be sure you have adequate coverage for your home as the winter weather approaches. Call or stop by our new Lake Grove location for a free quote.<br />
archdeaconagency.com</p>
<p>CARPET YOUR WORLD<br />
CENTEREACH<br />
Give your home a fresh new look for the holidays with new flooring. From carpets, hardwoods or laminates, we’ve got you covered. Vinyl, tile and rugs are also available.<br />
carpetyourworld.com</p>
<p>COW HARBOR GIFTS AND COLLECTIBLES<br />
NORTHPORT VILLAGE<br />
Store Closing!  Perfect gifts for the home.  20% off (min) everything in store!  Additional savings on Black Friday!<br />
           <br />
DISCOVER LONG ISLAND<br />
HAUPPAUGE<br />
Discover Long Island X Hamptons hand poured candle. Each candle is made using natural, clean-burning SOY and high quality fragrance blends. Take a piece of the Hamptons home with you. $30<br />
shop.discoverlongisland.com</p>
<p>DOUGLAS ELLIMAN<br />
EAST SETAUKET<br />
The Real Estate Market in our area is thriving and Douglas Elliman is here to help you safely maximize your most valuable asset. Call Team East Setauket today and ask us how we can help you join our growing list of sold homes<br />
elliman.com</p>
<p>GENREADY, INC.<br />
KINGS PARK<br />
Never be without power again. GenReady specializes in the installation of Generac generators. With over 41 years of experience we are committed to good service and installation practices. Your family will thank you!<br />
getgenready.com</p>
<p>J.M. TROFFA HARDSCAPE, MASON &#038; BUILDING SUPPLY, INC.<br />
EAST SETAUKET<br />
Transform your backyard into the perfect place to entertain or relax with a complete outdoor kitchen island, fireplace and fire pit. We carry the supplies you will need and work with your contractor.<br />
troffahardscape.com</p>
<p>JOS. M. TROFFA<br />
EAST SETAUKET<br />
No holiday is complete without the magic, warmth and beauty of a fireplace in your home. Joseph <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="1440667b7272755467617d6071">[email&#160;protected]</a> 9 has everything to light up your holidays and backyard fun through the seasons. Your full service masonry and landscape supply center.<br />
troffa.com</p>
<p>KUNZ GREENHOUSES<br />
PORT JEFFERSON STATION<br />
Bird Houses make the perfect gift! Choose from a selection of whitewashed bird houses or a locally handmade custom bird house. We also offer many other gift items. Starting at $19.99<br />
kunzgreenhouses.com</p>
<p>LAVENDER FIELDS<br />
PORT JEFFERSON<br />
We’ve moved! Visit us at our brand new location:  250 East Main Street, Port Jefferson. Your place for holiday décor and entertaining essentials:  gifts, candles, home décor, apothecary, bedding and interior design.<br />
lavenderfieldsonline.com</p>
<p>SEA CREATIONS<br />
PORT JEFFERSON<br />
Wood Wick Candles by Yankee.  Crackle as they burn…wonderful seasonal scents!<br />
seacreations.com</p>
<p>SETAUKET KITCHEN AND BATH<br />
SETAUKET<br />
Discover what a gorgeous new kitchen will do for the value of your home. Inquire about our free estimates or stop into our showroom.<br />
setauketkitchens.com</p>
<p>STONY BROOK FIRE DEPARTMENT<br />
STONY BROOK<br />
This holiday season, be sure your home is equipped with smoke and CO detectors, 9 volt batteries, flashlights, escape ladder, battery operated radio, hurricane preparedness kit and a residential sprinkler system.</p>
<p>THE REBOLI CENTER FOR ART AND HISTORY<br />
STONY BROOK<br />
Joseph Reboli Artwork. High quality reproductions of Reboli Originals. Custom sizes and frames available. Locally made, starting at $175.00<br />
rebolicenter.org </p>
<p>THREE VILLAGE HISTORICAL SOCIETY<br />
SETAUKET<br />
Discover the story of The Culper Spy Ring at TVHS and keep their legacy alive with a Culper Spy sweatshirt, t-shirt, mug, books and more. $9 &#8211; $50<br />
tvhs.org</p>
<p>THREE VILLAGE HISTORICAL SOCIETY<br />
SETAUKET<br />
Discover the history of the Three Village area with a custom framed historical photo from the TVHS archives. Makes a great gift!!  $20 &#8211; $40<br />
tvhs.org</p>
<p>For pets.</p>
<p>ANIMAL HEALTH &#038; WELLNESS VETERINARY OFFICE, P.C.<br />
EAST SETAUKET<br />
Give your pet something they can smile about this holiday with a professional dental cleaning. It’s important to your pet’s overall health<br />
amimalhealthwellness.com</p>
<p>ANIMAL HEALTH &#038; WELLNESS VETERINARY OFFICE, P.C.<br />
EAST SETAUKET<br />
Give your pet the medical care they need at your convenience with late night and weekend hours. Gift certificates.<br />
animalhealthwellness.com</p>
<p>CORNER ANIMAL HOSPITAL<br />
SETAUKET<br />
Give the gift of health with flea and tick protection for your pet.<br />
corneranimal.com</p>
<p>CORNER ANIMAL HOSPITAL<br />
SETAUKET<br />
Give the gift of health with a yearly checkup for your pet.<br />
www.corneranimal.com</p>
<p>COUNTRYSIDE ANIMAL HOSPITAL<br />
PORT JEFFERSON<br />
Looking for that perfect gift for your family’s furry friend?  Treat them to a “spa day” at Countryside.  We offer baths and grooming and a complimentary mani/pedi is always included.<br />
countrysideportjeff.com</p>
<p>SEA CREATIONS<br />
PORT JEFFERSON<br />
My Saint My Hero Pet Blessing Bracelets and Tags.  A portion of proceeds donated to Wags &#038; Walks.<br />
seacreations.com</p>
<p>Health &#038; Beauty</p>
<p>ANDREW MASTRONARDI, DMD<br />
PORT JEFFERSON STATION<br />
Whiter teeth for the holidays! Holiday special:  take home trays &#8211; $250. In-office whitening &#8211; $250. Gift certificates available.<br />
mastronardidental.com</p>
<p>HEARING &#038; TINNITUS MANAGEMENT, LLC<br />
STONY BROOK<br />
Stay connected this holiday season. Don’t let hearing loss limit you. Be proactive and schedule a hearing evaluation today.<br />
LI audiology.com</p>
<p>MADE TO MOVE TENNIS &#038; WELLNESS<br />
SETAUKET<br />
Give that special someone the gift of wellness with a gift card for private lessons, court time, or yoga.<br />
Madetomovewellness.com</p>
<p>MARK FREELEY<br />
WOODBURY<br />
I am a dedicated New York personal injury attorney with over 30 years of experience. Free consultation available 24/7. Let me help get your case the results you are looking for.<br />
northshoreinjurylawyer.com</p>
<p>O.B. DAVIS FUNERAL HOMES<br />
PORT JEFFERSON STATION, MILLER PLACE, CENTEREACH<br />
Planning your final arrangements in advance is one of the greatest gifts you can give.<br />
dignitymemorial.com</p>
<p>ST. JOHNLAND NURSING CENTER<br />
KINGS PARK<br />
St. Johnland Nursing Center provides skilled nursing care for your loved ones.  We offer Alzheimer’s/Dementia care, head injury rehab, adult day health care and social day care services.  Visit our website for further info.<br />
stjohnland.org</p>
<p>SEA CREATIONS<br />
PORT JEFFERSON<br />
Sprays and Therapies.  Inis, the fragrance that carries the Energy of the Sea.  Camille Beckman…her signature scent “Camille” and “French Vanilla”.<br />
seacreations.com</p>
<p>STONY BROOK VISION WORLD<br />
STONY BROOK<br />
Be in style this holiday season with our new Culper eyewear. Exclusive eyewear by Kazuo Kawasaki, Italee Optics, Prodesign, Oakley, Lacoste, Juicy Couture, Cazal, Jaguar, Porsche Design Carrera and more.<br />
stonybrookvisionworld.com</p>
<p>THE SPA AND SALON AT EAST WIND<br />
WADING RIVER<br />
Pamper that special someone with a Gift Card to the Spa to indulge in one of our exclusive treatments or packages. Order online, by phone or in person.<br />
eastwindlongisland.com</p>
<p>SUFFOLK VASCULAR &#038; VEIN CENTERS<br />
PORT JEFF STA., HAUPPAUGE, RIVERHEAD<br />
During the holidays, we spend more time on our feet. Do you suffer from leg pain or have varicose veins? We can help. Contact us at one of our three locations.<br />
suffolkvascular.com</p>
<p>VARICOSE VEIN CENTER<br />
PORT JEFFERSON<br />
Lovelier legs this holiday season. We can help.<br />
mdvein.com</p>
<p>YOUR CBD STORE<br />
PORT JEFFERSON STATION<br />
Give the Gift of Health and Beauty with our Holiday Beauty Bundle! Set includes scented bath bombs or salts and 1000mg tincture or assorted gummies. Bundles start at $50.<br />
cbdrx4u.com</p>
<p>Family</p>
<p>BURR TRAVEL<br />
NORTHPORT<br />
Give them memories that will last a lifetime…surprise them with a vacation!  Nothing beats time spent together.<br />
burrtravel.com</p>
<p>CARPET YOUR WORLD<br />
CENTEREACH<br />
Treat your family to a fresh new look for the holidays with new flooring in your home. From carpets, hardwoods or laminates, we’ve got you covered. Vinyl, tile and rugs also available.<br />
carpetyourworld.com</p>
<p>CHEESE AND SPICE MARKET<br />
WADING RIVER<br />
We carry a large selection of teas, teaware, cheeses, spices, salts and rubs as well as many gourmet items perfect for gift baskets.<br />
cheesespicemarket.com</p>
<p>COUNTRYSIDE ANIMAL HOSPITAL<br />
PORT JEFFERSON<br />
Looking for that perfect gift for your family’s furry friend?  Treat them to a “spa day” at Countryside.  We offer baths and grooming and a complimentary mani/pedi is always included.<br />
countrysideportjeff.com</p>
<p>COUNTRY HOUSE RESTAURANT<br />
STONY BROOK<br />
Holiday traditions start at The Country House Restaurant. It is the perfect place for all your family gatherings and functions.<br />
countryhouserestaurant.com</p>
<p>COW HARBOR GIFTS AND COLLECTIBLES<br />
NORTHPORT VILLAGE<br />
Store Closing!  Unique gifts for the ones you love.  20% (min) everything in store!  Additional savings on Black Friday, November 26.</p>
<p>DOUGLAS ELLIMAN REAL ESTATE<br />
EAST SETAUKET<br />
Looking to make a fresh start in 2022? Contact Douglas Elliman Real Estate to help you find that forever home!<br />
elliman.com</p>
<p>GENREADY, INC.<br />
KINGS PARK<br />
Never be without power again. GenReady specializes in the installation of Generac generators. With over 41 years of experience we are committed to good service and installation practices. Your family will thank you!<br />
getgenready.com</p>
<p>HAMLET WINES &#038; LIQUORS<br />
SETAUKET<br />
Stop by and we will help you choose the right wine to make any holiday meal memorable. Choose from hard to find wines, champagne, sparkling wines, Prosecco and Kosher wines. Custom gift baskets available.</p>
<p>HATCH<br />
HUNTINGTON<br />
Spread pancake love. With every $25 gift card purchase, score a free order of pancakes (now through December 24th. In store promotion only.)<br />
hatchbrunch.com</p>
<p>ISLAND EMPANADA<br />
ROCKY POINT, RONKONKOMA, MEDFORD, DEER PARK, HUNTINGTON STATION, COMMACK, MERRICK, SHIRLEY, OAKDALE &#038; LINDENHURST<br />
Island Empanada will cater your special occasion with a taste of the islands in every bite.<br />
islandempanada.com</p>
<p>J.M. TROFFA HARDSCAPE, MASON &#038; BUILDING SUPPLY, INC.<br />
EAST SETAUKET<br />
Transform your backyard into the perfect place to entertain or relax with a complete outdoor kitchen island, fireplace and fire pit. We carry the supplies you will need and work with your contractor.<br />
troffahardscape.com</p>
<p>JEFFERSON’S FERRY LIFE PLAN RETIREMENT COMMUNITY<br />
SOUTH SETAUKET<br />
Planning for retirement? Jefferson’s Ferry is expanding their wellness-focused community. Call our sales department for additional information and to schedule a tour.<br />
jeffersonsferry.org</p>
<p>JERSEY MIKE’S SUBS<br />
STONY BROOK, HAUPPAUGE, PORT JEFF STATION<br />
Catering for all your family events. Choose from our subs in a box or personal boxed lunches and remember our cookie and brownie trays for dessert.<br />
jerseymikes.com</p>
<p>JOS. M. TROFFA<br />
EAST SETAUKET<br />
No holiday is complete without the magic, warmth and beauty of a fireplace in your home. Joseph <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="5d092f323b3b3c1d2e28342938">[email&#160;protected]</a> 9 has everything to light up your holidays and backyard fun through the seasons. Your full service masonry and landscape supply center.<br />
troffa.com</p>
<p>KILWINS PORT JEFFERSON<br />
PORT JEFFERSON<br />
Step inside and indulge in the aroma and delight at the sight of our cases and find your go-to favorites. Having an event? Ask us about favors and party trays! Whether you’re in your hometown or visiting for the day, come in and experience why we are “Sweet in every Sense since 1947”. We now offer DoorDash for local delivery! Curbside pick-up always available!<br />
kilwins.com</p>
<p>MADE TO MOVE TENNIS &#038; WELLNESS<br />
SETAUKET<br />
Keep the family moving in a healthy direction all together with gift cards for private lessons, court time, and junior camps.<br />
madetomovewellness.com</p>
<p>DR. TARA MARTINEZ<br />
COMMACK<br />
“There is no place like home” says Dr. Tara Martinez and we welcome her back.  Minimally invasive colon and rectal surgery.  Call for appointment today.  Don’t delay screening and treatment.<br />
surgicalspecialistli.com</p>
<p>MOLONEY FAMILY FUNERAL HOMES<br />
PORT JEFFERSON STATION<br />
Our family is there for your family year round. Happy Holidays!<br />
moloneyfh.com</p>
<p>MARIO’S RESTAURANT &#038; BAR<br />
EAST SETAUKET<br />
There is nothing better than dinner out with the family. Take a break from holiday shopping and have lunch or weekend brunch with the ones you love.<br />
mariossetauket.com</p>
<p>MARK FREELEY<br />
WOODBURY<br />
I am a dedicated New York personal Injury attorney with over 30 years of experience. Free consultation available 24/7. Let me help get your case the results you are looking for.<br />
northshoreinjurylawyer.com</p>
<p>PASTA PASTA<br />
PORT JEFFERSON<br />
Thank you for our 30th anniversary and making us one of Port Jefferson’s favorite restaurants. We cater to you on and off premises. Personal service and intimate setting for lunch or dinner from 4 to 60 guests. Think of us for your holiday party catering needs. We offer a large selection of hot and cold party food and platters. Experience dining that can only be described as truly magnificent.<br />
pastapastaportjeff.com</p>
<p>PJ CINEMAS<br />
PORT JEFFERSON STATION<br />
You’ll never go wrong with a gift certificate to PJ Cinemas, where kids, seniors and matinees are just $6.50. Come see a movie today.<br />
mypjcinemas.com</p>
<p>SA GHAR INDIAN FUSION RESTAURANT<br />
PORT JEFFERSON<br />
SaGhar means “home of the sea”. Visit SaGhar and escape to the shores of India, experience a fusion between the many rich delicacies of India with local Port Jefferson fare. Create beautiful memories this holiday season. Catering and private events where every guest is treated like family<br />
sagharportjeff.com</p>
<p>SEISKAYA BALLET<br />
STONY BROOK<br />
Create a holiday tradition. Enjoy a scrumptious performance of “ The Nutcracker” Ballet at the Staller Center for the Arts.<br />
seiskaya.com</p>
<p>SETAUKET KITCHEN AND BATH<br />
SETAUKET<br />
Gather the family all year round in a delightful new entertainment room designed with cabinetry selected with your taste and budget uppermost in mind.<br />
setauketkitchens.com</p>
<p>STALLER CENTER<br />
STONY BROOK<br />
Tickets for the Russian National Ballet performance of Cinderella is the perfect family outing! This lavish and humorous family friendly production is a must see!<br />
stallercenter.com</p>
<p>STONY BROOK CHRISTIAN ASSEMBLY<br />
EAST SETAUKET<br />
Meet the crazy professor and travel back in time at the Stony Brook Christian Assembly “Living Nativity.”  Make this part of your family tradition.  Saturday, Dec. 4th , Sunday, Dec. 5th, Friday, Dec. 10th  and Saturday, Dec. 11th.  Each night from 6 – 9 pm.<br />
stonybrookchristian.com </p>
<p>STONY BROOK FIRE DEPARTMENT<br />
STONY BROOK<br />
This holiday season, be sure your home is equipped with smoke and CO detectors, 9 volt batteries, flashlights, escape ladder, battery operated radio, hurricane preparedness kit and a residential sprinkler system.</p>
<p>STONY BROOK VISION WORLD<br />
STONY BROOK<br />
Be in style this holiday season with our new Culper eyewear. Exclusive eyewear by Kazuo Kawasaki, Italee Optics, Prodesign, Oakley, Lacoste, Juicy Couture, Cazal, Jaguar, Porsche Design Carrera and more.<br />
stonybrookvisionworld.com</p>
<p>THEATRE THREE<br />
PORT JEFFERSON<br />
Celebrate the season with Long Island’s own holiday tradition. Join us for our 37th annual production of the immortal classic  &#8211;  A Christmas Carol with all of its thrills, music, joy and spirit. Performances through December 26th.<br />
theatrethree.com </p>
<p>THE SHOPPES AT EAST WIND<br />
WADING RIVER<br />
Shop Small Shop Local. You can find many gifts for the entire family at the Shoppes. Visit with Santa and ride Rudolph on the Carousel. Open daily.<br />
eastwindlongisland.com/shoppes</p>
<p>WIGGS OPTICIANS<br />
STONY BROOK<br />
Capture all your family’s special moments with Smart Ray-Ban Sunglasses. Now you can record live videos, take photo snapshots, listen to music, take a phone call and much more. Order a pair today.<br />
wiggsopticians.com</p>
<p>Dining and Catering</p>
<p>CHEESE AND SPICE MARKET<br />
WADING RIVER<br />
Order a custom cheese platter to wow your guests for the holidays! Choose from our over 100 cheeses and meats. We’ll do the rest!<br />
cheeseandspicemarket.com</p>
<p>DESMOND’S RESTAURANT AT EAST WIND<br />
WADING RIVER<br />
Gift certificates available. Great for Sunday brunch, a casual lunch or intimate dinner.  Open for Christmas Eve and New Year’s Eve dinner. Reservations required.<br />
eastwindlongIsland.com</p>
<p>HAMLET WINES &#038; LIQUORS<br />
SETAUKET<br />
Stop by and we will help you choose the right wine to make any holiday meal memorable. Choose from hard to find wines, champagne, sparkling wines, Prosecco and kosher wines. Custom gift baskets available.</p>
<p>ISLAND EMPANADA<br />
ROCKY POINT, RONKONKOMA, MEDFORD, DEER PARK, HUNTINGTON STATION, COMMACK, MERRICK, SHIRLEY, OAKDALE AND LINDENHURST<br />
Island Empanada will cater your special occasion with a taste of the islands in every bite.<br />
islandempanada.com</p>
<p>JERSEY MIKE’S SUBS<br />
STONY BROOK, HAUPPAUGE, PORT JEFF STATION<br />
What makes Jersey Mike’s so good? High quality meats and cheese sliced in front of you, store baked bread and authentic taste served Mike’s Way. Treat someone today. Gift cards available.<br />
jerseymikes.com</p>
<p>KILWINS PORT JEFFERSON<br />
PORT JEFFERSON<br />
Step inside and indulge in the aroma and delight at the sight of our cases and find your go-to favorites. Having an event? Ask us about favors and party trays! Whether you’re in your hometown or visiting for the day, come in and experience why we are “Sweet in every Sense since 1947”. We now offer DoorDash for local delivery! Curbside pick-up always available!<br />
kilwins.com</p>
<p>LESSING’S RESTAURANTS<br />
VARIOUS LOCATIONS<br />
Lessing’s GIFT CARDS. Now through December 24th with every $100 gift card purchase, receive a complimentary $20 gift card from us (valid in all Lessing’s Restaurants).<br />
lessings.com</p>
<p>MARIO’S RESTAURANT &#038; BAR<br />
EAST SETAUKET<br />
For all your holiday celebrations… dine in or take out. Serving lunch and dinner<br />
7 days a week with new specials every Friday. Brunch Saturdays and Sundays<br />
11 am – 3 pm. Happy hour daily 3 – 7 pm. On &#038; off premises catering.<br />
mariossetauket.com</p>
<p>PASTA PASTA<br />
PORT JEFFERSON<br />
Thank you for our 30th anniversary and making us one of Port Jefferson’s favorite restaurants. We cater to you on and off premises. Personal service and intimate settings for lunch or dinner from 4 to 60 guests. Think of us for your holiday party catering needs. We offer a large selection of hot and cold party food and platters. Experience dining that can only be described as truly magnificent.<br />
pastapastaportjeff.com</p>
<p>RUGGERO’S FAMILY STYLE RESTAURANT<br />
WADING RIVER<br />
Gift cards to Ruggero’s is a welcome gift and can be purchased online, by phone or in person. Holiday catering available. Open daily.<br />
ruggerosrestaurant.com</p>
<p>SA GHAR INDIAN FUSION RESTAURANT<br />
PORT JEFFERSON<br />
SaGhar means “home of the sea”. Visit SaGhar and escape to the shores of India, experience a fusion between the many rich delicacies of India with local Port Jefferson fare. Create beautiful memories this holiday season. Catering and private events where every guest is treated like family<br />
sagharportjeff.com</p>
<p>SETAUKET GOURMET DELICATESSEN &#038; CATERERS<br />
EAST SETAUKET<br />
Planning a special Holiday gathering? We offer elegantly presented cuisine from hot entrees to sumptuous dessert platters and everything in between!<br />
setauketgourmet.com</p>
<p>SETAUKET KITCHEN AND BATH<br />
SETAUKET<br />
An upgraded, efficient new kitchen designed by Setauket Kitchen and Bath can make dining and entertaining at home a pleasure.<br />
setauketkitchens.com</p>
<p>THEATRE THREE<br />
PORT JEFFERSON<br />
After dinner, come celebrate the season with Long Island’s own holiday tradition. Join us for our 37th annual production of the immortal classic – A Christmas Carol in all of its thrills, music, joy and spirit. Performances through December 26th.<br />
theatrethree.com</p>
<p>Affordable Luxuries</p>
<p>BURR TRAVEL NORTHPORT<br />
Give them memories that will last a lifetime…surprise them with a vacation!  Nothing beats time spent together.<br />
burrtravel.com</p>
<p>DISCOVER LONG ISLAND<br />
HAUPPAUGE<br />
Discover Long Island and Gage Sunglasses collaborated to release a limited edition pair of sunnies to show your true Long Island pride!  $30<br />
shop.discoverlongisland.com</p>
<p>DOUGLAS ELLIMAN REAL ESTATE<br />
EAST SETAUKET<br />
Looking to make a fresh start in 2022? Contact Douglas Elliman Real Estate to help you find that forever home!<br />
www.elliman.com</p>
<p>EAST WIND LONG ISLAND<br />
WADING RIVER<br />
A Gift of a Getaway is what you can get with a gift card from East Wind. Long Island’s premier North Fork destination, elegant wedding venue, luxury hotel, spa and dining.<br />
eastwindlongisland.com</p>
<p>ECOLIN JEWELERS<br />
PORT JEFFERSON<br />
Timeless sterling silver bracelets, necklaces, earrings and rings from premier designers. ecolin.com</p>
<p>LAVENDER FIELDS<br />
PORT JEFFERSON<br />
We’ve moved! Visit us at our brand new location:  250 East Main Street, Port Jefferson. Your place for holiday décor and entertaining essentials:  gifts, candles, home décor, apothecary, bedding and interior design.<br />
lavenderfieldsonline.com</p>
<p>SETAUKET GOURMET DELICATESSEN &#038; CATERERS<br />
EAST SETAUKET<br />
Setauket Gourmet is here to help you plan all of your holiday gatherings. We offer family dinners, party platters, hot and cold hours d’oeuvres, dessert platters and so much more!<br />
setauketgourmet.com</p>
<p>SETAUKET KITCHEN AND BATH<br />
SETAUKET<br />
Create the luxury kitchen or bath of your dreams. Stop by our showroom and we’ll help you get started.<br />
setauketkitchens.com </p>
<p>STALLER CENTER<br />
STONY BROOK<br />
Give the gift of the Arts this holiday season. Visit our website for a listing of all upcoming shows.<br />
stallercenter.com</p>
<p>THEATRE THREE<br />
PORT JEFFERSON<br />
Consider a Holiday Gift Subscription to see the shows your family wants all year long….a great gift for anyone! Gift certificates to individual shows are available.<br />
theatrethree.com</p>
<p>WIGGS OPTICIANS<br />
STONY BROOK<br />
For anyone on your holiday list, Smart Ray-Ban Sunglasses, With the tap of a button, record live videos, take photo snapshots, listen to music, take phone calls and much more. Order today.<br />
wiggsopticians.com</p>
<p>His</p>
<p>DISCOVER LONG ISLAND<br />
HAUPPAUGE<br />
Unisex “Where I Belong” Champion Crewneck. Stay warm in our navy blue Champion pullover sweatshirt screen printed with our exclusive “Where I Belong” design.  $38<br />
shop.discoverlongisland.com</p>
<p>DISCOVER LONG ISLAND<br />
HAUPPAUGE<br />
Long Island Beanie Hat. Keep warm this holiday season with our marbled grey beanie that features our signature “Long Island, New York” logo patch.  $25<br />
shop.discoverlongisland.com</p>
<p>ECOLIN JEWELERS<br />
PORT JEFFERSON<br />
Rugged natural stone bead bracelets with designer clasps or men’s accessories including money clips, keychains and pocket knives.<br />
ecolin.com</p>
<p>JOS. M. TROFFA<br />
EAST SETAUKET<br />
No holiday is complete without the magic, warmth and beauty of a fireplace in your own home. Joseph <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="4c183e232a2a2d0c3f3925382975">[email&#160;protected]</a>, has everything you need to light up your holidays and backyard fun through the seasons. Your full service masonry and landscape supply center.<br />
troffa.com </p>
<p>SUFFOLK VASCULAR &#038; VEIN CENTERS<br />
PORT JEFF STA., HAUPPAUGE, RIVERHEAD<br />
During the holidays, we spend more time on our feet. Do you suffer from leg pain or have varicose veins? We can help. Contact us at one of our three locations.<br />
suffolkvascular.com</p>
<p>THEATRE THREE<br />
PORT JEFFERSON<br />
Looking for something different to do? Grab some friends and enjoy a comedy show or a show on the main stage at Theatre Three. Gift certificates available for individual shows or year long subscriptions.<br />
theatrethree.com</p>
<p>WIGGS OPTICIANS<br />
STONY BROOK<br />
For the guy who has everything, Smart Ray-Ban Sunglasses. He will love to record live videos, take photo snapshots, listen to music, take phone calls and much more. Order a pair today.<br />
wiggsopticians.com</p>
<p>Hers</p>
<p>CHRISTINA’S HANDBAGS<br />
PORT JEFFERSON<br />
Stuff stockings with something that matters &#8211; accessories from Christina’s Handbags in Port Jefferson on Main. 20 &#8211; 50% off everything &#8211; our gift to you.<br />
christinasfashionhandbags.com </p>
<p>DISCOVER LONG ISLAND<br />
HAUPPAUGE<br />
Long Island Beanie Hat. Keep warm this holiday season with our marbled grey beanie that features our signature “Long Island, New York” logo patch.  $25<br />
shop.discoverlongisland.com</p>
<p>DISCOVER LONG ISLAND<br />
HAUPPAUGE<br />
Unisex “Where I Belong” Champion Crewneck. Stay warm in our navy blue Champion pullover sweatshirt screen printed with our exclusive “Where I Belong” design.  $38<br />
shop.discoverlongisland.com</p>
<p>ECOLIN JEWELERS<br />
PORT JEFFERSON<br />
GOLD,GOLD,GOLD…chains, bracelets, earrings, rings and crosses.<br />
ecolin.com</p>
<p>JOS. M. TROFFA<br />
EAST SETAUKET<br />
No holiday is complete without the magic, warmth and beauty of a fireplace in your own home. Joseph <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="376345585151567744425e43520e">[email&#160;protected]</a>, has everything you need to light up your holidays and backyard fun through the seasons. Your full service masonry and landscape supply center.<br />
troffa.com</p>
<p>THEATRE THREE<br />
PORT JEFFERSON<br />
Plan a special date night with a show at Theatre Three…she will be sure to love it.<br />
Gift Certificates are available so she can pick the show she wants to see most.<br />
theatrethree.com</p>
<p>THE SPA AND SALON AT EAST WIND<br />
WADING RIVER<br />
Pamper that special someone with a Gift Card to the Spa to Indulge in one of our exclusive treatments or packages, Order online, by phone or in person.<br />
eastwindlongisland.com</p>
<p>SUFFOLK VASCULAR &#038; VEIN CENTERS<br />
PORT JEFF STA., HAUPPAUGE, RIVERHEAD<br />
During the holidays, we spend more time on our feet. Do you suffer from leg pain or have varicose veins? We can help. Contact us at one of our three locations.<br />
suffolkvascular.com</p>
<p>VARICOSE VEIN CENTER<br />
PORT JEFFERSON<br />
Lovelier legs this holiday season. We can help.<br />
www.mdvein.com</p>
<p></marquee>
</div>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><p><a href="https://tbrnewsmedia.com/epaper/"><br />
<img loading="lazy" border="0" alt="Read Our Newspapers Online" src="https://tbrnewsmedia.com/wp-content/uploads/2017/05/tbr_read_online_banner_w.jpg" width="336" height="150"><br />
</a></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><p><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-oio-zone="type=banner&#038;zone=4&#038;align=center&#038;refresh=0"> 
(function(w,d,e,o,u,s,t){w[o]||(w[o]={},s=d.createElement(e),s.src=u,s.async=1, 
t=d.getElementsByTagName(e)[0],t.parentNode.insertBefore(s,t))})(window,document, 
"script","oiopub","https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/zones.js"); 
</script></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><p><script data-oio-zone="type=banner&#038;zone=4&#038;align=center&#038;refresh=0"> 
(function(w,d,e,o,u,s,t){w[o]||(w[o]={},s=d.createElement(e),s.src=u,s.async=1, 
t=d.getElementsByTagName(e)[0],t.parentNode.insertBefore(s,t))})(window,document, 
"script","oiopub","https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/zones.js"); 
</script></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><p><script data-oio-zone="type=banner&#038;zone=4&#038;align=center&#038;refresh=0"> 
(function(w,d,e,o,u,s,t){w[o]||(w[o]={},s=d.createElement(e),s.src=u,s.async=1, 
t=d.getElementsByTagName(e)[0],t.parentNode.insertBefore(s,t))})(window,document, 
"script","oiopub","https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/zones.js"); 
</script></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"></br><script type="text/javascript" src="https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/js.php#type=banner&align=center&zone=2"></script></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><p><a href="https://tbrnewsmedia.com/wp-content/uploads/2021/06/06-10-21-CW-Solution.jpg"><br />
<img loading="lazy" src="https://tbrnewsmedia.com/wp-content/uploads/2016/02/crossword-answers.jpg" alt="Crossword Puzzle" width="336" height="65" border="0" /><br />
</a></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><script data-oio-zone="type=banner&zone=4&align=center&refresh=0"> 
(function(w,d,e,o,u,s,t){w[o]||(w[o]={},s=d.createElement(e),s.src=u,s.async=1, 
t=d.getElementsByTagName(e)[0],t.parentNode.insertBefore(s,t))})(window,document, 
"script","oiopub","https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/zones.js"); 
</script></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"></br><script type="text/javascript" src="https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/js.php#type=banner&align=center&zone=2"></script></div>
		</aside><aside class="widget widget_mc_mm_widget"><div class='mailmunch-wordpress-widget mailmunch-wordpress-widget-53899' style='display: none !important;'></div></aside><aside class="widget widget_text">			<div class="textwidget"><script type="text/javascript" src="https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/js.php#type=banner&align=center&zone=2"></script></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><script data-oio-zone="type=banner&zone=4&align=center&refresh=0"> 
(function(w,d,e,o,u,s,t){w[o]||(w[o]={},s=d.createElement(e),s.src=u,s.async=1, 
t=d.getElementsByTagName(e)[0],t.parentNode.insertBefore(s,t))})(window,document, 
"script","oiopub","https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/zones.js"); 
</script></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><br><script type="text/javascript" src="https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/js.php#type=banner&align=center&zone=2"></script></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><p><script data-oio-zone="type=banner&#038;zone=4&#038;align=center&#038;refresh=0"> 
(function(w,d,e,o,u,s,t){w[o]||(w[o]={},s=d.createElement(e),s.src=u,s.async=1, 
t=d.getElementsByTagName(e)[0],t.parentNode.insertBefore(s,t))})(window,document, 
"script","oiopub","https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/zones.js"); 
</script></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><p><script data-oio-zone="type=banner&#038;zone=4&#038;align=center&#038;refresh=0"> 
(function(w,d,e,o,u,s,t){w[o]||(w[o]={},s=d.createElement(e),s.src=u,s.async=1, 
t=d.getElementsByTagName(e)[0],t.parentNode.insertBefore(s,t))})(window,document, 
"script","oiopub","https://tbrnewsmedia.com/wp-content/plugins/oiopub-direct/zones.js"); 
</script></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><p><!--<a href="https://tbrnewsmedia.com/wp-content/uploads/2018/05/one_life_to_give.pdf">
<img loading="lazy" src="https://tbrnewsmedia.com/wp-content/uploads/2018/05/oltg_screening.jpg" alt="One Life To Give" width="336" height="242" border="0" />
</a>--></p>
</div>
		</aside>                </div>
            
                             </div>
                        </div>
                    </div>
                </div>
            </div>
        </div>
            <div class="td-footer-wrap">
        <div class="container">
            <div class="row">
                
                            <div class="span12">
                                <div class="td-grid-wrap">
                                    <div class="container-fluid">
                                        <div class="wpb_row row-fluid ">
                                            <div class="span4 wpb_column column_container">
                                                <div class="footer-logo-wrap"><img src="https://tbrnewsmedia.com/wp-content/uploads/2015/03/TBR_logo_2015_web.png" alt=""/></div><div class="footer-text-wrap">TBR News Media is your local news and entertainment website. </div><div class="footer-text-wrap">We provide you with the latest breaking news and information for your community. </div><div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#8befeef8e0cbffe9f9e5eefcf8fbeafbeef9f8a5e8e4e6"><span class="__cf_email__" data-cfemail="80e4e5f3ebc0f4e2f2eee5f7f3f0e1f0e5f2f3aee3efed">[email&#160;protected]</span></a></div><aside class="widget widget_text">			<div class="textwidget">Call Us: 631-751-7744</div>
		</aside>                                            </div>

                                            <div class="span4 wpb_column column_container">
                                                <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_td_uid_1_61bb9eab76d2f = new td_block();
block_td_uid_1_61bb9eab76d2f.id = "td_uid_1_61bb9eab76d2f";
block_td_uid_1_61bb9eab76d2f.atts = '{"category_id":"","category_ids":"","tag_slug":"","sort":"random_7_day","autors_id":"","hide_title":"","installed_post_types":"","limit":"3","offset":"","header_color":"#","header_text_color":"#","custom_title":"Most Viewed","custom_url":"","title_style":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","ajax_pagination_infinite_stop":""}';
block_td_uid_1_61bb9eab76d2f.td_cur_cat = "";
block_td_uid_1_61bb9eab76d2f.td_column_number = "1";
block_td_uid_1_61bb9eab76d2f.block_type = "4";
block_td_uid_1_61bb9eab76d2f.post_count = "3";
block_td_uid_1_61bb9eab76d2f.found_posts = "59";
block_td_uid_1_61bb9eab76d2f.max_num_pages = "20";
block_td_uid_1_61bb9eab76d2f.header_color = "#";
block_td_uid_1_61bb9eab76d2f.ajax_pagination_infinite_stop = "";
td_blocks.push(block_td_uid_1_61bb9eab76d2f);
</script><div class="td_block_wrap td_block4"><h4 class="block-title"><span >Most Viewed</span></h4><style>.ui-sctd_uid_1_61bb9eab76d2f .cur-sub-cat { color:# !important}</style><div id=td_uid_1_61bb9eab76d2f class="td_block_inner">
        <div class="td_mod3 td_mod_wrap " itemscope itemtype="https://schema.org/Article">
        <div class="thumb-wrap"><a href="https://tbrnewsmedia.com/money-matters-what-are-your-financial-resolutions-for-2022/" rel="bookmark" title="Money Matters: What are your financial resolutions for 2022?"><img width="100" height="65" itemprop="image" class="entry-thumb" src="https://tbrnewsmedia.com/wp-content/uploads/2021/12/Financial-Resolutions-100x65.jpg" alt="" title="Money Matters: What are your financial resolutions for 2022?"/></a></div>        <div class="item-details">
            <h3 itemprop="name" class="entry-title"><a itemprop="url" href="https://tbrnewsmedia.com/money-matters-what-are-your-financial-resolutions-for-2022/" rel="bookmark" title="Money Matters: What are your financial resolutions for 2022?">Money Matters: What are your financial resolutions for 2022?</a></h3>            <div class="meta-info">
                                <time  itemprop="dateCreated" class="entry-date updated" datetime="2021-12-12T13:11:17+00:00" >December 12, 2021</time><meta itemprop="interactionCount" content="UserComments:0"/>                            </div>
        </div>
        <meta itemprop="author" content = "Michael Christodoulou">        </div>

        
        <div class="td_mod3 td_mod_wrap " itemscope itemtype="https://schema.org/Article">
        <div class="thumb-wrap"><a href="https://tbrnewsmedia.com/attorney-at-law-does-my-trust-need-an-ein/" rel="bookmark" title="Attorney At Law: Does my trust need an EIN?"><img width="100" height="65" itemprop="image" class="entry-thumb" src="https://tbrnewsmedia.com/wp-content/uploads/2021/12/taxes-1015399_960_720-e1639332991110-100x65.jpg" alt="" title="Attorney At Law: Does my trust need an EIN?"/></a></div>        <div class="item-details">
            <h3 itemprop="name" class="entry-title"><a itemprop="url" href="https://tbrnewsmedia.com/attorney-at-law-does-my-trust-need-an-ein/" rel="bookmark" title="Attorney At Law: Does my trust need an EIN?">Attorney At Law: Does my trust need an EIN?</a></h3>            <div class="meta-info">
                                <time  itemprop="dateCreated" class="entry-date updated" datetime="2021-12-12T13:08:51+00:00" >December 12, 2021</time><meta itemprop="interactionCount" content="UserComments:0"/>                            </div>
        </div>
        <meta itemprop="author" content = "Nancy Burner Esq., CELA">        </div>

        
        <div class="td_mod3 td_mod_wrap " itemscope itemtype="https://schema.org/Article">
        <div class="thumb-wrap"><a href="https://tbrnewsmedia.com/your-turn-port-jefferson-dickens-festival-extended-through-dec-18/" rel="bookmark" title="Your Turn: Port Jefferson Dickens Festival extended through Dec. 18"><img width="100" height="65" itemprop="image" class="entry-thumb" src="https://tbrnewsmedia.com/wp-content/uploads/2019/12/DSC_0196-100x65.jpg" alt="" title="Your Turn: Port Jefferson Dickens Festival extended through Dec. 18"/></a></div>        <div class="item-details">
            <h3 itemprop="name" class="entry-title"><a itemprop="url" href="https://tbrnewsmedia.com/your-turn-port-jefferson-dickens-festival-extended-through-dec-18/" rel="bookmark" title="Your Turn: Port Jefferson Dickens Festival extended through Dec. 18">Your Turn: Port Jefferson Dickens Festival extended through Dec. 18</a></h3>            <div class="meta-info">
                                <time  itemprop="dateCreated" class="entry-date updated" datetime="2021-12-09T11:12:43+00:00" >December 9, 2021</time><meta itemprop="interactionCount" content="UserComments:0"/>                            </div>
        </div>
        <meta itemprop="author" content = "TBR Staff">        </div>

        </div></div> <!-- ./block1 -->                                            </div>
                                            <div class="span4 wpb_column column_container">
                                                                                            </div>
                                        </div>
                                    </div>
                                </div>
                            </div>

                                    </div>
        </div>
    </div> <!-- /.td-footer-wrap  -->



<div class="td-sub-footer-wrap">
    <div class="container ">
        <div class="row">
            <div class="span12">
                <div class="td-grid-wrap">
                    <div class="container-fluid">
                        <div class="row-fluid ">
                            <div class="span4 td-sub-footer-copy">
                                &copy;                             </div>
                            <div class="span8 td-sub-footer-menu">

                                <div class="menu-td_demo_footer-container"><ul id="menu-td_demo_footer" class=""><li id="menu-item-1470" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-1470"><a title="Terms of Use" href="https://tbrnewsmedia.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-715" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-715"><a title="Privacy Policy" href="https://tbrnewsmedia.com/privacy-policy/">Privacy policy</a></li>
<li id="menu-item-2230" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2230"><a href="https://tbrnewsmedia.com/site-map/">Site Map</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-706"><a title="Advertising" href="https://tbrnewsmedia.com/advertising">Advertising</a></li>
<li id="menu-item-1730" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1730"><a href="https://tbrnewsmedia.com/subscribe/">Subscribe</a></li>
<li id="menu-item-705" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-705"><a title="Contact Us" href="https://tbrnewsmedia.com/contact">Contact Us</a></li>
<li id="menu-item-15146" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-15146"><a href="https://tbrnewsmedia.com/contact/">Call Us: 631-751-7744</a></li>
</ul></div>                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </div>
</div>


</div>
<!--/#inner-wrap-->
</div>
<!--/#outer-wrap-->

<div class="td-sp td-scroll-up"></div>



    <!--

        Theme: Newspaper by tagDiv 2014
        Version: 4.5d (rara)
        Deploy mode: deploy
        
        uid: 61bb9eabbee4b
    -->

    <script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/tbrnewsmedia.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tbrnewsmedia.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.7' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://tbrnewsmedia.com/wp-content/themes/Newspaper/js/td_external.js?ver=4.5d' id='td-external-js'></script>
<script type='text/javascript' src='https://tbrnewsmedia.com/wp-content/themes/Newspaper/js/full_compact/site.js?ver=4.5d' id='td-site-js'></script>
<script type='text/javascript' src='https://tbrnewsmedia.com/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>
<script type='text/javascript' src='https://tbrnewsmedia.com/wp-includes/js/comment-reply.min.js?ver=5.7.1' id='comment-reply-js'></script>

<!-- JS generated by theme -->

<script>
    
</script>

<script type="text/javascript">(function(){window['__CF$cv$params']={r:'6beb6193cab85b3a',m:'.XJ_P0ynW1PrACY8JEGdxbC.t8nc1TxOZw9u30MYNyo-1639694088-0-AZ/IlxzQtMc9C5EGCBO0U49g7dkUESudTdonk4SGJaDIuSsR6c9xctH9M2c76o7NWlq5cTX5NltqQFJ+cHpzZzoeJiLEOSa/WfJ0k5pwjB1dh8yQ2q9Q300ydlvJMjq7mWBvCpV/40HLaCj/UYI9mkc=',s:[0x5147fab796,0x56c4989b42],u:'/cdn-cgi/challenge-platform/h/g'}})();</script></body>
</html>